Tag Archives: Fuel Regulator

A leaking fuel pressure regulator will cause your vehicle to be hard to start and may blow black smoke. This is an easy problem to check on most vehicles.


Olds Aurora EVAP smoke test

I have a 2003 Oldsmobile Aurora Final 500. Replaced the manifold gasket and Catalytic Converter over the past 4 weeks, and was planning to replace a bad coil pack this week. I do not drive more than 80 – 100 miles a week, usually less. The car ran good except for a misfire that could be felt at idle and low speeds (under 50mph). Also…

Continue reading


2000 Hyundai Santa Fe Hard To Start

I have a 2000 Hyundai Santa FE and if it sits a couple of hours or more it is hard to start. Can you help me? ProTech: When a vehicle sits for a while after it has been run or driven, the engine goes through what is called a ‘heat soak’. This means it basically gets hotter for a little bit before cooling off. This…

Continue reading


Check Engine Light P0102- Replaced MAF And Other Sensors

To Whom It May Concern: I have replaced the following parts:In reference to the P0102 code 1) Plugs and Wires (AC Delco). 2) Fuel pump and fuel filter. 3) Fuel regulator. 4) Air filter. 5) New Battery. 6) New fuel injector (No 1 cyl). 7) Checked fuses (O.K.). SENSORS: 1) AIT (Air intake temperature) 2) MAP 3) MAF 4) EVAP Purge control solenoid All new…

Continue reading


2003 Chevrolet Monte Carlo Starts And Stalls

I have a 2003 Chevrolet Monte Carlo with 3.4 Liter engine. I have had all kinds of starting issues…..First it would only start on the 2nd try for quite a while. I replaced the fuel filter, fuel pump, crank sensor. Finally got where it would not start at all. I broke down and took it to a mechanic that put it on the diagnostic machine…

Continue reading


Buick Regal Has Rough Idle

I have a 1995 Buick Regal. All of a sudden it seems to load up on fuel rough idle, have replaced a new fuel pump in and that didn’t help. Car has to be primed to get started. Once it runs it’s fine unless you shut if off then it has to be primed again before it will start. I am at a loss as…

Continue reading


Chevrolet S-10 Truck Starting Problems Answered

1994 Chevrolet S-10 4.3 tbi. I never get the signal to turn on the fuel pump or fire the injectors but if i poor gas in the intake once the truck starts it runs fine. Any ideas ? I have replaced the fuel pump relay oil pressure switch and computer. ProTech: If you’re not getting a signal for fuel, then you either have a faulty crank…

Continue reading


1999 Chevy Silverado Hard Time Starting

I have a 1999 Chevy Silverado with 5.3 It is hard starting and has a miss at low RPM around 1500 and then it clears up when you accelerate. Any ideas what may be the cause. ProTech Does the problem go away when the truck warms up? No it doesn’t it still does it when warm. Ok, usually the intake gaskets leaking will cause a…

Continue reading


1994 Buick Century P0341 Cam Sensor Code

I have a 1994 Buick Century v6 3.1 and im having 2 main problems. My first problem is I replaced the crank and cam sensors awhile ago and while everything went fine with the crank im having some problems with the cam sensor. When I got the new one in it gave me a P0341 code so I looked at it and it was faulty…

Continue reading


2002 Chevy Trailblazer Dies Out

My 2002 Chevrolet Trailblazer stalls when sitting at a red light but not all the time,rpms go up then drop to 200 and car cuts off,already cleaned throttle body,changed fuel filter,changed map sensor,changed exhaust cam actuator solenoid and still stalls,any ideas would be greatly appreciated! ProTech: Is the check engine light on at all when it dies out? No check engine lite. Ok, it does…

Continue reading


2002 Pontiac Grand Am Temp Sensor and Hard Starting

Trouble code says IAT sensor on 2002 Pontiac Grand Am GT 3.4L. Have replaced it twice with two brand new ones from different stores. Still showing problem code. Has problems with no start or hard start after sitting for a few hours. Runs fine when engine is warm. Could it be a broken or shorted wire in the IAT sensor circuit that just isn’t visible…

Continue reading


2003 Chevy Trailblazer No Engine Power

I have a 2003 Chevy Trailblazer with 146,00 miles on it, the problem is lack of engine power, I put the scanner and it showed up this code P0172, I did fuel injection service, replaced fuel filter, also changed spark plugs & cleaned up the throttle body. any ideas? ProTech: How about the air filter? Have you checked that? Yes i changed it as well.…

Continue reading


2000 Chevy Camaro Engine Runs Rough

Hi, 2000 Chevy Camaro v6 3.8 motor. Used to stall when driving, replaced plugs wires, and a coil pack and runs good, but seems to stall out on turns, but not all of the time, code p0300 comes on and goes off. Not sure what it is, and also starts hard at times. ProTech: Have you checked fuel pressure? Yes, its about 48 at start…

Continue reading