Chevy Blazer Transmission Problems And Won’t Start

I have a 1994 Chevrolet Blazer with the 4.3 ltr Vortec Motor. I am getting gas to schrader valve on motor but not to the spider fuel injector.

The two plastic fuel lines between the hard metal lines and injector spider sometimes leak into the plenum which would limit fuel going to the spider. Also, on the side of the spider unit there is a regulator that can rupture and also leak fuel into the plenum which limits fuel to the injector poppets. If you can remove the upper plenum (intake) and have a look, you should be able to see if any leaks are present. Usually a portion of the lower intake will be all clean from where fuel has been spraying where it normally does not. If neither of those is your problem, do a fuel pressure check. You can have fuel at the valve but not have enough pressure to start the truck.


Transmission Not Pulling

My Chevrolet blazer broke down this morning. I heard a pop noise then the transmission it wouldn’t pull any more. It restarted it and it dragged but started still wont pull. The drive shaft appeared in-tacked.

What year Blazer are you driving? Does the truck move at all in drive or reverse?

It is a 1994 Chevy Blazer. No it wont move in drive or reverse gear.

Does the engine seem to rev up ok in park? Any noises when revving it up in drive or reverse?

Seems to be ok when the engine is revved up.

Check the transmission fluid level. Add some if it is low.  Also smell it to see if it smells burned. See if there are bubbles on the dipstick. Do this with engine running in park. Let me know what you find…

Ok!! Thank you!! Will let ya know :)

 

 


Leave comments below or see these