94 Buick Century 3.1 revs high and accelerating problem

< Back to Buick Forums    << Back to ALL Forums
  • Author
    Posts
  • #12525 Reply

    Anonymous

    I am having issues with my Buick.

    I have had the code for the EGR valve come up and replaced it twice, but car is still acting up. It revs really high and erratically when in park, also seems to be having an issue accelerating after coming to a stop and then trying to go. gains speed and seems to get gas after a few seconds ok though. Also at times as car seems to switch gears it feels like a slight slip at times. Also if I back up rather fast the car has stalled out. Had a mechanic look at several times o one can seems to diagnose. Had fuel pressure checked and came back ok too.

    Please any help.

    I read online that it may be a throttle body position sensor or a crankshaft sensor. Does any of those seems more likely?

  • #12626 Reply

    Cars suck

    REPLY:

    The throttle position sensor can be the most likely problem for the idling high and revving up higher than normal. The spring inside the sensor breaks and then basically it turns at will causing erratic readings and rpm changes. That’s a pretty easy part to change, so I’m sure you could do it yourself. As for the EGR problems, you could have chunks of carbon that keep getting stuck inside the valve which will set a code. Usually a really good cleaning of the EGR passages with a small wire brush/cleaner can take care of the problem.

Reply To: 94 Buick Century 3.1 revs high and accelerating problem
Your information:




<a href="" title="" rel="" target=""> <blockquote cite=""> <code> <pre> <em> <strong> <del datetime=""> <ul> <ol start=""> <li> <img src="" border="" alt="" height="" width="">