Common GM Engine Sensor Locations And Pictures

View Pictures of engine sensor locations for many GM vehicles. Click images for info.

Picture of the GM 3.8L 3800 V6 EngineThe 3800 V6 engine is one of the most reliable and widely used engines for General Motors. All series are based off of the 3.8L engine block. Used in Chervolet, Pontiac, Oldsmobile and Buick Models.

 

 

3400 or 3100 V6 engine sensor locations.The 3100 and 3400 engines are the same as the 3.1L and 3.4L. This engine has been used for many years in cars like the Chevy Malibu, Pontiac Grand Am, Oldsmobile Alero and Cutlass, Buick Regal.

 

 

4.2L engine sensor locations.The 4200 inline straight Six cylinder engine was very popular in the GMC Envoy, Chevy Trailblazer and Oldsmobile Bravada.

 

 

 

2.2L and 2.4L Ecotec engine sensor locations.2.2L and 2.4L Ecotec four cylinder engine sensor locations. This engine is widely used on smaller GM cars.


Leave comments below or see these

6 responses on “Common GM Engine Sensor Locations And Pictures

  1. Timothy Willmore

    i have a 2007 Buick Lucerne 4.8v and when I put a system in the car, I started to experience problems with the actual cutting on of the car.. Given, the shift gear linkage is pretty loose, but it will only start if the display screen reads PARK. which sometimes it doesn’t.. The only way to get the car to start now is if i put it in reverse, push the car a little, then when the display reads PARK, I can switch over to DRIVE. What is wrong? And where do i start, trying to fix this problem?

  2. octavio santiago

    I have a 2004 gmc 1500 sierra that the check engine light is on I used a detector tool and it indicated displayed that the engine had an evapovative systems problem I can’t locate the senor please help

  3. Rae Wallace

    my 2002 dodge durango 5.9 is down shifting at 60 an sometimes not shifting out of second.i was told this was a sensor,if it is what sensor an where is it located>? please help tyvm

  4. dennis kubichka

    I have 1989 dodge ram pickup. I put new spark plug and wires in it. I gaped the spark plugs to .035” like the motor calls for. The motor run like it should. But when i put the truck in gear the truck shakes like hell. please get back to me a,s,a,p, thank you dennis

  5. Valerie Whalen

    I am a little miffed. Not only does my gas gushed show empty when I just filled it but my temperature gauge stopped functioning ? Could this be a fuse ?

Leave a Reply

Your email address will not be published.