Category Archives: GMC

GMC truck repair questions and answers. Expert mechanics offer free help, information and advice.


GMC Envoy P0894 Slipping transmission

P0894 code I have 2005 GMC Envoy. I already changed fluid and filter when driving it will shift in 1st and 2nd fine then when gets to 3rd it will just idle real high like it’s in neutral. I have to keep giving gas and letting off until it hits gear. Is my trans shot…

Continue reading


1991 GMC Sonoma baby gas pedal till up to speed

I have a 1991 GMC Sonoma, 2.8 liter TBI engine, 5 speed, 81,000 miles that bogs downs when you give it gas you can baby the gas pedal to get up to speed but its still not quite right. This is more severe in cold weather than warm but there is still some what the…

Continue reading


GMC Yukon SLT 2008 Struts

Hello. I have a 2008 GMC Yukon SLT that has a bad driver side strut. I purchased a set of Detroit Axle strut kits, but they don’t have the electronics like the OEM struts. Is it necessary to replace these with the electronic version or can a regular non-electronic strut be installed? They fit just…

Continue reading


Gmc truck hose on manifold

There is a hose on top of manifold and it goes to the back of dash board what is the name of the part the hose is connected to by the back of dashboard Answer: Does this hose actually go inside the truck and into the dash board, or does it go the the firewall…

Continue reading


GMC Safari Fuel pump vibrating loudly

i have a 1996 GMC Safari i changed fuel pump in the tank it worked fine for about 10 miles then it just died while going 30 mph and a loud vibrating sound came from the tank and car wouldnt start and everytime i turned the key forward that same loud vibrating sound happens. So…

Continue reading


1500 GMC Has Fuel Pressure But Won’t Start

I have a 1994 GMC S1500 4.3 I t would shut down on me I was able several times to restart with either I replaced fuel filter fuel pump i and even ran direct power to the pump with an on/off switch the truck ran about 10 miles perfect than shut down like it had…

Continue reading


2001 GMC Safari Coolant Leak and Rough Idle

Hello. My son has a 2001 GMC Safari with a 4.3 engine. He complained of a “rough idle” along with a coolant leak. Not knowing what the rough idle might be, I suggested he bring a new set of spark plugs. I listened to the engine then looked and found a bad left side motor…

Continue reading


GMC Canyon Code P0116 Temperature Sensor And P0102 MAF

2006 GMC Canyon. When you push on the gas to take off it hesitates, while I am driving you can feel the engine hesitating, and when I slow down to stop it hesitates and the RPMs jerk and it stalls but if a pump the gas a little when it hesitates while I am stopping…

Continue reading


Warm Air From GMC Sierra Vents With A/C On

A/c compressor kicks on when ac is turned on, but no cold air comes out of the vents. You can change which vents the air comes out of. The ac is fully charged. When heat is on it only blows hot and can’t change to cooler heat. The vent output speeds can be changed. Any…

Continue reading


GMC Sierra A/C Clutch | Chevy Malibu Blows Warm Air

2000 GMC Sierra 1500 4.3 Vortec v-6. The clutch went out on my A/C unit. Do I have to replace the whole system or can I replace the clutch and bearing only? Will I have any freon leak when I remove the clutch and bearing? For now I have rerouted the serpentine belt to continue to…

Continue reading


1996 GMC Sierra Heat Defroster Controls Not Working

Live Chat I have a 1996 GMC 3500 Sierra 7.4 Litre. Battery cable came loose, arced and blew fuses. Replaced fuses and all was well. later, when I tried to turn on defrosters- I have absolutely no controls working at all (Heat/Defrost). Blower is running on high, but are cold. I have 2 buttons (AC…

Continue reading


High Beam Indicator On The Dash Of My GMC 2500

Why is the high beam light on in the dash of my 2004 GMC 2500 pick up when the truck is off and the high beam lever is off. ProTech: You’re probably looking at a short in the headlamp wiring somewhere, or even possibly a faulty instrument cluster. Every thing else works fine. I just…

Continue reading