Buick Lesabre Stalls Out And Check Engine Light

1995 Buick Lesabre-check engine light would come on; car would die in traffic; and car would buck or lung while in drive. a complete tune up of replacement wires and plugs were done.Crank sensor and computer was changed 2 weeks ago. This past weekend the car returned to same problems and computer was burned up. Had to be replaced today. i feel it laboring while in drive and lunges were slight again. What could have burned up the computer so soon after replacement and why would it be lunging?

OK. When you say burned up, do you just mean it went bad, or it actually burned up?

It went bad and the mechanic said “It burned up”.

The running bad is a precursor to something shorting out the computer. Could be a rubbing wiring harness under the hood. Try moving harnesses around with car running to see if you can get it to act up.

If this happens , what do I need to do or tell the mechanic?

If you can get it to act up, show him which harness you were moving. Have seen harnesses rub behind alternator as it passes the intake manifold and goes down back of engine on this vehicle.

1994 Buick Lesabre Custom

3.8l v6. When i step on the gas from a stopped or rolling position it has no get and go and it takes its dear sweet time getting up to speed, but once its up to speed, no issues, i could step on it and get up and going plenty fast, just not from a stop.

It could be a clogged catalytic converter, or a fuel system problem like a clogged fuel filter. You may also want to check the fuel pressure regulator for leaks. And make sure you have no vacuum leaks such as at the upper intake or PVC system.

Ok, cool thank you i will give that a try, but i will be back if it don’t work. Just one more question. This problem stated after we found out that the cooling fan relay (both high and low fans) are no good and we put new ones in, would that make a difference?

That really shouldn’t have made a different in acceleration. Thank you for visiting!

My sister 1999 Buick Regal broke the belt tensioner. We replaced it and now the car won’t start no fuel but I don’t know why.

I have no idea why replacing the tensioner would cause your car not to start….it is either something else, and a coincidence, or you broke or disconnected something when you did the job. It is possible that when the tensioner broke and the belt flew off it may have damaged the crank position sensor. This would cause the car to have no fuel injector pulse ior spark.

Leave comments below or see these